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1. Introduction
1.1 Preface
Elecard Stream Analyzer is a powerful tool designed for syntax analysis of encoded media streams and
presentation of the analysis log in a human readable form. Stream Analyzer operates with MPEG-1
Video/Audio, MPEG-2 Video/Audio, AAC, Dolby Digital Audio, MPEG-4, AVC/H.264, VC1,
HEVC/H.265, VVC/H.266, AVS3, AV1 and VP9 contained in MPEG-1 SS, MPEG-2 PS, TS, MP4,
AVI, FLV, IVF and MKV/WebM, HEIC files.

1.2 Describing Elecard Stream Analyzer
The following section defines the specifications and features of Elecard Stream Analyzer.

1.2.1 Supported Media Types
Elecard Stream Analyzer supports the following formats:
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

MPEG-1 Video stream (ISO/IEC 11172-2);
MPEG-2 Video stream (ISO/IEC 13818-2);
AVC/H.264 Video stream (ISO/IEC 14496-10) and its Annex G (SVC) and Annex H (MVC);
HEVC/H.265 Video stream (ISO/IEC 23008-2, MPEG-H Part 2);
VVC/H.266 Video stream (ISO/IEC 23090-3);
VP9 Bitstream Overview for Google VP9;
AV1 Bitstream & Decoding Process Specification;
AVS3 Video stream (Information Technology Intelligent Media Coding (T/AI 109.2 — 2021)
by Industry Alliance Standard));
MPEG-4 Video stream;
VC-1 Video;
MPEG-1/2 Audio Layer 1/2/3 (ISO/IEC 11172-3 and ISO/IEC 13818-3);
Dolby Digital Audio (ATSC A-52);
AAC (Advanced audio coding);
LPCM (Linear Pulse Code Modulated Audio);
SCTE-35 (ANSI/SCTE-35);
DVB Subtitle (ETSI EN 300 743);
MPEG-1 System Stream (MPEG-1, MPEG-1/2 Audio Layer 1/2/3, LPCM) (ISO/IEC 11172-1);
MPEG-2 Transport Stream (MPEG-1/2, AVC, HEVC, MPEG-1/2 Audio Layer 1/2/3, LPCM,
AC-3, AAC, SCTE-35, DVB Subtitle) (ISO/IEC 13818-1);
MPEG-2 Program Stream (MPEG-1/2, AVC, HEVC, MPEG-1/2 Audio Layer 1/2/3, LPCM,
AC-3, AAC) (ISO/IEC 13818-1);
AVI file container (MPEG-1/2, AVC, HEVC, LPCM, AC-3, AAC);
MP4 file container (MPEG-1/2, AVC, HEVC, VP9, AV1, VC-1, AC-3, AAC);
MKV file container (MPEG-1/2, AVC, HEVC, VP9, AV1, MPEG-1/2 Audio Layer 1/2/3, AC3, AAC);
WebM file container based on MKV (VP9, AV1);
IVF file container (VP9, AV1);
FLV file container (AVC, HEVC, AAС, LPCM);
HEIC file container.
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1.2.2 Features
Elecard Stream Analyzer implements the following features:
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Selection of packets in a text;
Selection of packets by PID and StreamID;
Stream viewing in the hex, ascii and binary modes;
Storing information about the stream and currently selected packets into a .CSV file;
Search of elements by offset, PID and text;
Transport stream error detection (ETSI TR 101 290) and analysis, error report generation;
Interleaving analysis;
Presentation of the interleaving between two streams as a diagram;
Calculation of the overhead in transport, program and system streams;
Bandwidth information;
Customization main control output;
MP4, AVI, MKV/WebM, FLV, IVF, HEIC support;
Cross platform (Windows, Mac, Linux version);
Selection of the data portion for further saving;
Dump elementary streams to file;
Build graphics from parameters;
Sharing comments between application instances and/or applications of Elecard StreamEye
Studio set;
Synchronization between applications of Elecard StreamEye Studio set (Binding mode);
Console version.

1.3 Using this Guide
1.3.1 Purpose
This guide is intended to help the user utilize Elecard Stream Analyzer. It describes the Stream Analyzer
GUI, settings and functions and provides instructions for Stream Analyzer use.

1.3.2 Topics Covered
Section 1: Introduction – provides a general overview of Stream Analyzer and describes the purpose
of the document and its contents.
Section 2: Getting Started – describes how to install, uninstall, and run the Elecard Stream Analyzer
program.
Section 3: Using Elecard Stream Analyzer – describes the Stream Analyzer GUI and provides
instructions for comparing video streams and viewing the results of comparison.

1.4 System Requirements
1.4.1 Software Requirements
•
•

Ubuntu 18/20.04 LTS, x64;
CentOS 7.6 x86_64.

__________________________________________________________________________
www.elecard.com
sales@elecard.com

5

Elecard Stream Analyzer 2022
User Guide
__________________________________________________________________________

1.5 Licensing and Technical Support
By installing, copying, or otherwise using the software product or any updates, you agree to be bound
by the terms of the "Elecard'' End-User License Agreement (''EULA''). This EULA is a legal agreement
between you (either an individual or a single entity) and Elecard for the "Elecard" software product(s)
accompanying this EULA, which include(s) computer software and may include "online" or electronic
documentation, associated media, and printed materials (''software product'').
For technical support, please contact Elecard Technical Support Team: tsup@elecard.com.
For sales and licensing information contact Elecard Sales Department: sales@elecard.com.

1.6 Activating Elecard Stream Analyzer
1.6.1 Sentinel License Protection
Make sure that Sentinel License Manager software has been installed on your computer. License
Manager is provided within the product installation pack for Windows OS and macOS and installed
automatically.
License Manager is provided as a separate installation pack for Linux OS and should be installed
manually.
Please note, Linux OS reinstallation will make the activated product license invalid.
To check that License Manager is properly installed, go to Sentinel Admin Control Center at
http://localhost:1947. If you see your license information, the installation is successfully completed.

Figure 1.

The License Manager with license information

License Manager allows configuring, controlling, monitoring and looking through a list of available
licenses. For more details on License Manager operation click the Help tab.
Note, each page contains the Help tab related to this page only.
You can activate Elecard Stream Analyzer offline via following steps:
For Elecard Stream Analyzer activation, a C2V (client-to-vendor) file should be created. To create the
C2V file follow the steps:
1. Open the File tab and select Options in the drop-down menu.
2. A dialog window should open. Open the License tab.
__________________________________________________________________________
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3.

Select HASP-SL for PC-based or HASP-HL for dongle-based activation in the Offline activation
with license files field. Note, if you select a PC-based (HASP-SL) activation, full featured
activated Elecard Stream Analyzer will run only on this particular hardware. If you have Elecard
dongle, plug it into a free USB port on your computer and select dongle-based (HASP-HL)
activation. It will be possible to use Elecard Stream Analyzer on any hardware with the dongle
plugged in.

Figure 2.

Offline activation with license files

4. Click the Collect license information button. The Save File dialog box should open. Click Save
and save the C2V file to a required directory. Send the saved C2V file to Elecard Sales at
sales@elecard.com.

Figure 3.

Creating a C2V file: License tab

5. After receiving the V2C file containing license information back from Elecard Sales save the
received file to a required directory. Open the File tab and select Options in the drop-down menu
again. Open the License tab and click Apply license update (see Figure 4). The file selection
dialog box should appear. Choose the received V2С file and click OK. Your application is
successfully activated.
__________________________________________________________________________
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2. Getting Started
The following section details the procedures for installing and running Elecard Stream Analyzer.

2.1 Installing Elecard Stream Analyzer
Elecard Stream Analyzer is supplied as part of Elecard StreamEye Studio or as a standalone application.
The application is installed via Elecard StreamEye Studio installer or Elecard Stream Analyzer installer.
Depending on the purchased product or version, the installation file is located:
• in /opt/Elecard/StreamAnalyzer/bin folder as a separate application;
• in /opt/Elecard/Elecard StreamEye Studio/StreamAnalyzer/bin folder as part of Elecard
StreamEye Studio.
The console is located in /opt/Elecard/StreamAnalyzer/bin folder.
To install Stream Analyzer on Linux OS, follow the steps below:
• Install the Stream Analyzer software by running the StreamAnalyzer-4.x-Linux.deb file.
• Install Sentinel Runtime (Sentinel License Manager allows using the license).

2.2 Uninstalling Elecard Stream Analyzer
Elecard Stream Analyzer can be uninstalled as a part of Elecard StreamEye Studio or as a standalone
application.
Depending on the operating system, there are two options of uninstalling the application.
1. To delete the Elecard application from Ubuntu:
• Enter the command in the terminal: sudo apt remove <application>;
• Or using the Ubuntu Software icon:
o When Ubuntu Software opens, click the Installed button at the top.
o Select the application that you want to delete, click Remove and Confirm the
application remove.
o You will be asked to authenticate by entering your password. After authentication
the application will be removed.
2. To delete the Elecard application from CentOS:
• Enter the command in the terminal: sudo yum remove <application>.

2.3 Running Elecard Stream Analyzer
To run Elecard Stream Analyzer as a part of StreamEye Studio, click Menu → Applications → Elecard
StreamEye Studio → Elecard Stream Analyzer.
To run Elecard Stream Analyzer, click Menu → Applications → Elecard Stream Analyzer.
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3. Using Elecard Stream Analyzer
3.1 Introduction
The following section describes the Elecard Stream Analyzer GUI (graphic user interface), its features
and instructions for stream analysis. The Elecard Analyzer is an advanced video analysis software tool
standing out for its simple user-friendly interface and in-depth statistics analysis.

3.2 Describing Elecard Stream Analyzer GUI
The following section describes the Elecard Stream Analyzer GUI.

Figure 4.

Elecard Stream Analyzer GUI

3.2.1 Menu
The following table describes the Elecard Stream Analyzer menu.
Table 1. Elecard Stream Analyzer GUI – Menu

Menu item

Button

Description
File

Open file

Opens a new media file for analysis.

Reopen

Reopens a list of recently opened files.

Reopen Last
File

Reopens the last opened file.
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Save

Allows selecting file information to be saved:
• Stream Info – saves all information on a stream;
• Dump – extracts and saves a piece of a file or an elementary stream and
allows choosing the required data portion.

Close

Closes the opened file.

Binding mode

Enables or disables the Binding mode:
• Leader – allows sending comments, commands on interface or positioning
changes to other applications;
• Follower – allows receiving comments, commands from other applications.

Open
comments
Save
comments
Copy the Full
Path
Open
Containing
Folder

Opens comments from the XML file.
Saves comments to the XML file.
Copies full path to the opened file.
Opens the current file location in Explorer.

Open with

Opens the current file with an external application (the application name and its path
are set in the Open With List field by opening Options – Main. Player is set by
default).

Options

Opens the program settings dialog (Main, Binding, License).

Exit

Exits the application.

Navigation
Offset

Enables searching by the offset.

Search text
box
Previous /
Next

Enables searching the necessary byte sequence in the file (helps to search for startcodes).
Switches the searching results: previous / next.

View
Explorer

Enables/disables the Explorer panel

Property
Sync mode

Enables/disables the Property panel:
• automatically changes data displayed in the Property panel

Compare mode

• compares the chosen packet with the selected one.

Dump mode

• saves an elementary stream selected in the Explorer panel.

Hex Viewer

Enables/disables the Hex Viewer panel

Time
Dynamics

Enables/disables the Time Dynamics panel

Messages

Activates the Messages panel

TR101-290

Activates the TR101-290 panel

Graphics

Enables/disables the Graphics panel

Comments

Enables/disables the Comments panel

Help
Contents

Opens the current User Guide in .pdf format

Feedback

Sends the feedback on Stream Analyzer via e-mail, if it is registered in the system with
the following subjects: Submit an Idea, Ask a Question, Report a Bug.
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About

Shows the About window.

3.2.2 Explorer Panel

Figure 5.

Elecard Stream Analyzer GUI – Explorer Panel – TS Stream

To open the Explorer panel, click View – Explorer.
This panel shows the stream hierarchical tree and allows managing information display in the Main
window panel. Left-click on the element shows all properties in the Property panel. Right-click on the
element shows the shortcut menu.
The Percentage field shows the percentage rate of an element in the whole stream.
When choosing some stream element, you can see two more functions in the Property panel.
The Dump button saves the dump file.
Use checkboxes to select data that you need displayed in the Main Window panel.
MP4 streams have descriptive headers that contain detailed information about MP4 boxes (atoms),
which is displayed in the panel.
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Figure 6.

Elecard Stream Analyzer GUI – Explorer Panel – MP4 Stream

AVI streams have descriptive headers that contain detailed information about AVI chunks, which is
displayed in the panel.

Figure 7.

Elecard Stream Analyzer GUI – Explorer Panel – AVI Stream

MKV streams have descriptive headers that contain detailed information about MKV elements, which
is displayed in the panel.

Figure 8.

Elecard Stream Analyzer GUI – Explorer Panel – MKV Stream
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3.2.3 Main Window Panel
This panel contains information about packets.

Figure 9.

Elecard Stream Analyzer GUI – Main Window Panel

Circles on the left side of the panel indicate type of information displayed.
The red circle stands for an error, the blue one is either a warning or a message.
Offset indicates the beginning of the packet position in the file. Types of packets are color coded. Braces
show the parameters that can be chosen in the Property panel.
The scrollbar indicates red and blue messages found in the displayed packets. Search results are
highlighted orange.
Click the packet to see corresponding data in the Property panel, Hex Viewer panel and Messages
panel. Double left-click on the packet in the Main Window panel opens property data of the
corresponding packet. To select the required data range, left-click or right-click and press the Shift key.
To expand/collapse packet property data in Main Window Panel, use Right/Left arrow keys. Navigation
through stream elements is provided using the hotkey Shift + Up/Down arrows;
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3.2.4 Property Panel
This panel indicates properties of the chosen packet.

Figure 10.

Figure 11.

Elecard Stream Analyzer GUI – Property Panel – Detailed Information about packet (from the Main Window Panel)

Elecard Stream Analyzer GUI – Property Panel – Detailed Information about stream (from the Explorer Panel)
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Figure 12.

Elecard Stream Analyzer GUI – Property Panel – Detailed Information about chosen box (atom) (from the Explorer
Panel)

To display a parameter in the Main Window panel, right-click on the necessary parameter and choose
Show in header title. To hide a parameter, click on the button in front of a parameter in the Property
panel.
Compare mode – the chosen packet will be compared with the previous chosen one. The
differences in parameters will be highlighted blue.
Sync mode – automatically changes data displayed in the Property panel without left-clicking
the Main Window panel
Dump – a function in the explorer mode for saving elementary stream.

3.2.5

Hex Viewer Panel

Figure 13.

Elecard Stream Analyzer GUI – Hex Viewer Panel

The HEX viewer represents a file in the hex mode and allows navigation by the offset. The buttons also
provide ascii

and binary

modes.
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In the Columns drop-down list, you can choose number of bytes to show in the panel.
The Offset field
allows searching by the offset.
The Search text box allows searching the necessary byte sequence in the file (helps to search for startcodes).

3.2.6

Messages Panel

Figure 14.

Elecard Stream Analyzer GUI – Messages Panel

The Messages panel displays a log of the stream errors analysis. The left panel is used to form the list
of errors indicated in the log. It also provides a list of possible error or message types. If an error occurs,
it is highlighted blue and you see the number of errors or messages found in the file. The right panel
provides a list of occurred errors or messages. The red color stands for first priority errors. The blue
color is the indicator of warnings and errors of second and third priority.
Double-clicking the line in the right panel sets position in Main Window to the packet comprising the
selected error.

3.2.7 TR101-290 Panel

Figure 15.

Elecard Stream Analyzer GUI – TR101-290 Panel

The TR101-290 panel displays a log of the transport stream analysis. The left panel is used to form the
list of errors indicated in the log. It also provides a list of possible error or message types. If an error
__________________________________________________________________________
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occurs, it is highlighted blue and you see the number of errors or messages found in the file. The right
panel provides a list of occurred errors or messages. The red color stands for first priority errors. The
blue color is the indicator of warnings and errors of second and third priority.
Double-clicking the line in the right panel sets position in Main Window to the packet comprising the
selected error.
If an indicator is set, then the TS is in error. However, since the indicators do not cover the entire range
of possible errors, it cannot be concluded that there is no error if the indicator is not set.
If the TS sync loss indicator is activated then all other indicators are invalid. Each indicator is activated
only as long as at least one of the description lines is fulfilled.
Note: In the case of indicators requiring a minimum repetition rate of sections, it means that each and
every section that is present for this table should have the stated repetition rate.
Any test equipment intended for the evaluation of these parameters should report test results by means
of the indicators itemized in the second column of the tables followed below. The tables describe
detectable errors according to their priority types.
Table 2. First Priority Errors

Error

Description

TS sync loss

Loss of synchronization with consideration of hysteresis parameters.

Sync. byte error

Sync_byte is not equal to 0x47

PAT error

Continuity count error

PMT error

Sections with table_id 0x00 do not occur at least every 0,5 s on PID 0x0000
Section with table_id other than 0x00 found on PID 0x0000
Scrambling_control_field is not 00 for PID 0x0000
Incorrect packet order
a packet occurs more than twice
lost packet
Sections with table_id 0x02, (i.e. a PMT), do not occur at least every 0,5 s on each
program_map_PID which is referred to in the PAT.
Scrambling_control_field is not 00 for all packets containing information of sections with
table_id 0x02 (i.e. a PMT) on each program_map_PID which is referred to in the PAT.
Referred PID does not occur for a user specified period.

PID error

Table 3. Second Priority Errors

Error

Description

Transport error

Transport_error_indicator in the TS-Header is set to "1"

CRC error

CRC error occurred in CAT, PAT, PMT, NIT, EIT, BAT, SDT or TOT table

PCR repetition error

Time interval between two consecutive PCR is longer than 40 ms

PCR discontinuity indicator
error

The difference between two consecutive PCR values (PCRi+1 – PCRi) is outside the range
of 0...100 ms without the discontinuity_ indicator set

PCR accuracy error

PCR accuracy of selected program is not within ±500 ns

PTS error

PTS repetition period is longer than 700 ms

CAT error

Packets with transport_scrambling_control not 00 present, but no section with table_id =
0x01 (i.e. a CAT) present
Section with table_id other than 0x01 (i.e. not a CAT) found on PID 0x0001
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Table 4. Third Priority Errors

Error

NIT actual error

NIT other error
SI repetition error
Unreferenced PID

SDT actual error

SDT other error

EIT actual error

EIT other error

EIT PF error
RST error

Description
Section with table_id other than 0x40 or 0x41 or 0x72 (i. e. not an NIT or ST) found on
PID 0x0010
No section with table_id 0x40 (i.e. an NIT_actual) in PID value 0x0010 for longer than 10
s.
Any two sections with table_id = 0x40 (NIT_actual) occur on PID 0x0010 within a
specified value (25 ms or lower).
Interval between sections with the same section_number and table_id = 0x41 (NIT_other)
on PID 0x0010 longer than a specified value (10s or higher).
Repetition rate of SI tables is outside of the specified limits
PID (other than PMT_PIDs, PIDs with numbers between 0x00 and 0x1F or PIDs user
defined as private data streams) is not referred to by a PMT or a CAT within 0,5 s
Sections with table_id = 0x42 (SDT, actual TS) is not present on PID 0x0011 for more
than 2 s
Sections with table_ids other than 0x42, 0x46, 0x4A or 0x72 found on PID 0x0011.
Any two sections with table_id = 0x42 (SDT_actual) occur on PID 0x0011 within a
specified value (25 ms or lower)
Interval between sections with the same section_number and table_id = 0x46 (SDT, other
TS) on PID 0x0011 longer than a specified value (10s or higher)
Section '0' with table_id = 0x4E (EIT-P, actual TS) is not present on PID 0x0012 for more
than 2 s
Section '1' with table_id = 0x4E (EIT-F, actual TS) is not present on PID 0x0012 for more
than 2 s
Sections with table_ids other than in the range 0x4E - 0x6F or 0x72 found on PID 0x0012
Any two sections with table_id = 0x4E (EIT-P/F, actual TS) occur on PID 0x0012 within a
specified value (25ms or lower)
Interval between sections '0' with table_id = 0x4F (EIT-P, other TS) on PID 0x0012 longer
than a specified value (10s or higher);
Interval between sections '1' with table_id = 0x4F (EIT-F, other TS) on PID 0x0012 longer
than a specified value (10s or higher).
If either section ('0' or '1') of each EIT P/F subtable is present both must exist. Otherwise
EIT_PF_error should be indicated
Sections with table_id other than 0x71 or 0x72 found on PID 0x0013.
Any two sections with table_id = 0x71 (RST) occur on PID 0x0013 within a specified
value (25 ms or lower)

3.2.8 Time Dynamics Panel

Figure 16.

Elecard Stream Analyzer GUI – Time Dynamics Panel

The Time Dynamics panel represents the interleaving between two streams as a diagram. To specify
the streams, use the drop-down lists in the panel.
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Figure 17.

Elecard Stream Analyzer GUI – Time Dynamics Panel - Panel

The chart can be built using DTSs or PTSs. If DTSs and PTSs are used together, the DTS values are
used as primary ones. If DTS is absent, the PTS values are used.
These visualization options allow selecting the following Base stream characteristics for analysis (if data
exists in the stream):
⚫

PTS/DTS Dynamics – indicates variation of PTS/DTS with the Offset changing for the selected
PID

⚫

PCR Dynamics – indicates variation of PCR with the Offset changing for the selected PID

⚫

PCR/PTS Dynamics – indicates variation of PTS/DTS in relation to the PCR values with the
Offset changing for the selected PID

⚫

Offset/PCR Dynamics – indicates variation of Offset between the PCR values for the selected
PID

⚫

PCR Accuracy – indicates the difference between the actual and expected PCR values for the
selected PID within the range of +-500 ns.

Moving the cursor over the window, you can see the values corresponding to the given points of the
graph. Left click pins the cursor on the graph. Double-click displays the given packet in Main Window.
Clicking the Fit button
Buttons

and

you can resize the graphic, fitting it to your screen.
zoom the graphic in and out, respectively.

3.2.9 Graphics Panel

Figure 18.

Elecard Stream Analyzer GUI – Graphics Panel

The Graphics panel serves to compare parameters of the streams.
You can add several parameters to compare. Go to the Property panel, right-click on the necessary
parameter, choose Add to Graphic Control. The parameter will be added to the Graphics panel.
The panel allows setting up visual representation of data. The graphic can be viewed in Line, Bar and
Transition modes. Also, you can choose ranging by Offset or by Count in the drop-down menu.
Clicking the Fit button

you can resize the graphic, fitting it to your screen.
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Buttons
and
zoom the graphic in and out, respectively.
Stream structure – saves stream structure in the Explorer panel.
Full stream structure – saves only checked elements in the Explorer panel.
Messages – saves general info about errors.
Message details – saves all errors with their descriptions.
Visible elements – saves only opened elements in the Main Window panel.
Element data – saves all elements in the Main Window panel.

3.2.10 Comments Panel
The Comments panel is designed for team work: share comments on a specific frame or group of frames
in the stream, navigation and switching between different instances of the same application or different
applications contained in Elecard StreamEye Studio. Comments are created in the Main Window panel
of the application by left-clicking (or right-clicking and pressing the shift button) and selecting the
required field.

Figure 19.

Elecard Stream Analyzer GUI – Comments Panel

The Comment dialog should open. Enter comments in the corresponding field.

Figure 20.

Elecard Stream Analyzer GUI – Comment Dialog

The comment parameters can be edited or changed before or after they are saved. To save the comment
click File ->Save Comments and select the folder. When the comment is chosen, its position is
displayed in Main window and highlighted green.
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To edit, remove or send comments using the Binding mode, open the context menu by right-clicking.
The Send option enables you to pass the selected comment to the other application of StreamEye Studio
set or the other instance of Stream Analyzer. To select an application from which messages should be
received or to select a type of messages to be received, go to the Options tab – Binding or see more
details in the Options Window section.

3.2.11 EPG Panel

Figure 21.

Elecard Stream Analyzer GUI – EPG Panel

The EPG panel displays scheduling information for current and upcoming broadcast programming. The
Text mode represents programming information in a column. The TimeLine mode shows both
information column and timeline field with time stamps. In case the successive timestamps are presented
in a stream, space between them can be distributed by clicking the
and
buttons in the
TimeLine mode. To see detailed information about the programming, hover cursor over its headline.

3.2.12 Saving Stream Information
The Save option allows saving different types of data: the stream itself, stream structure and information,
headers, messages, errors, elements, comments, etc. To select and configure the data to be saved, open
the Save tab from the File drop-down menu or click the
button.
To save only information about the stream (without saving the stream as it is), select the Stream Info
tab. A dialog window should open.
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Figure 22.

Elecard Stream Analyzer GUI – Save Window – Stream Info

Stream structure – saves stream structure in the Explorer panel.
Full stream information – saves only checked elements in the Explorer panel.
Range – allows selecting a range to save data contained there:
•
•

All – saves information on the whole stream;
Offset – saves information on a stream portion limited by the specified offsets.

Messages – saves general information about errors.
Message details – saves errors with all details.
TR101-290 – saves general information about types of errors and their number.
TR101-290 details – saves detailed information about errors.
Headers – saves all headers without their structure.
Visible only – saves only headers selected in the Explorer panel and displayed in the Main Window
panel.
Headers details – saves all headers with their structures selected in the Explorer panel and displayed
in the Main Window panel.
To save a stream or its portion, select the Dump tab. A dialog window should open.
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Figure 23.

Elecard Stream Analyzer GUI – Save Window – Dump

Select an Elementary stream to be dumped as a whole or within a specified range.
Range – allows selecting a range to save data contained there:
• All – saves information on the whole stream;
• Offset – saves information on a stream portion limited by the specified offsets.

3.2.13 Options Window
To open the Options window, select the Options tab from the File drop-down menu or click the
button. The Options window allows opening a file with an external application, specifying the
application name and path, specifying the number of files in a list, saving data, configuring Binding
mode settings.
Specify the number of recent files to be displayed in a list. The default value is 10 files.

Figure 24.

Elecard Stream Analyzer GUI – Options – Main Tab
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On attempt to open a file from a list that does not exist any longer, a message notifying that the file is
missing occurs. It is recommended to delete missing files from the list. To enable automatic deletion of
missing files, set the checkbox for Delete missing recent files from list automatically.
To open the file currently opened in Stream Analyzer with another application, specify its name and path
in the Open with field according to parameters specified there. The parameters path and shortcut are
optional. If the path parameter is not specified, default application or player supporting a file format and
installed in the system is opened. Each string specified in the Open with field corresponds to an
individual item in the menu File – Open with, that allows easy switching between applications or players
after configuring the field.
Note: The Restore Defaults button allows you to reset set options to their original values. Functionality of this button
is not applicable to the License tab.

The Visualization tab contains the Color theme setting that allows selecting light (default) or dark colors
of the GUI background.
By activating the Show PTS, DTS, PCR in hexadecimal checkbox, all PTS, DTS, PCR values will be
represented in the hexadecimal format.

Figure 25.

Elecard Stream Analyzer GUI – Options – Visualization tab

The Binding tab contains settings that allow configuration of the interaction between Elecard
StreamEye Studio applications. In the Binding Mode, exchanging information between applications is
provided via a specified port. By activating checkboxes, you can select which applications should send
messages and set messages type that should be communicated. Additionally, the synchronization of
applications window size and switching between controls can be enabled.
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Figure 26.

Elecard Stream Analyzer GUI – Options – Binding Tab

Receive messages from the application – allows selecting the applications contained in Elecard
StreamEye Studio from which messages are received: StreamEye, StreamAnalyzer, VideoQuest.
Messages type to be received from the selected application – allows selecting a type of messages to
be received from the selected applications:
• Position – positioning in bitstream in different applications but within the same video file
(available only if the same video file is opened in different applications).
• Comments – allows receiving comments from the selected applications (available for all
selected applications contained in Elecard StreamEye Studio)
GUI Synchronization – allows synchronizing the application window size and switching between
internal controls (available for StreamAnalyzer only).
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Figure 27.

Elecard Stream Analyzer GUI – Options – Save Tab

The Save tab in the Options dialog allows saving data using the following options:
• Decimal separator in .csv file - allows selecting decimal comma or decimal dot to separate an
integer part from a fractional one of a real number.
• Data delimiter in .csv file - allows selecting comma or semicolon to specify boundaries in data
stream.
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4. Command Line Tool
Elecard Stream Analyzer functionality is available in console version now, so you can run the tool from
the command line.
Stream Analyzer Command Line tool is designed for insight into MPEG-1 Video/Audio, MPEG-2
Video/Audio, AAC, Dolby Digital Audio, AVC/H.264, VC1, HEVC/H.265, VVC/H.266, AV1, AVS3,
and VP9 contained in TS, PS, MP4, AVI, FLV, IVF, MKV/WebM and HEIC file formats.
Stream Analyzer Command Line tool allows automatic analysis of video arrays. You can customize a
sequence of commands to perform your specific tasks and automate your routine tasks.
To streamline automatic analysis of several files the following rules are introduced. They reassign
input and output parameters for configuration files.
Get to the command prompt by clicking Start->Run and type 'cmd'. Then enter the command to start the
application first and proceed with the command line options. In general, the syntax is as follows:
./streamanalyzer-cli config.xml /in:input.ts /out:output

Note: You should not relocate the <product> console without all the other applications of the product
contained in the installation pack, otherwise the console application will not start.
Notes on the command line rules:
1. Parameters with default value are not required and can be omitted;
2. Rules for input and output file names:
⚫
⚫
⚫
⚫

parameter /in:<file path> in the command line overwrites the value of the tag <input/> in the
configuration file;
parameter /out:<file prefix> in the command line overwrites the value of the tag <output/> in the
configuration file;
if <output/> tag is missing (or not specified), output file names are formed from input file name
plus suffix (if the latter is specified);
if output file for a tag/section is not specified, the output file name for the tag/section is formed
from the name specified in the <output/> tag plus suffix depending on the name of the tag/section,
e.g. ".message.csv", ".header.csv", etc.

in

input file path

out

output files prefix

file path

path to the file

config path

path to the config file

sfx

suffix of all output files in config

dc

use current run directory as default path for files

4.1 Configuration file
Sample Config.xml file – contains all the commands performed by the application and reflects overall
operation results:
<SA version="1">
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<input file="..."/>
<output storage="union(default)/split" separator=";(default)/,"
delimiter=".(default)/," file="..."/>
<range start="(default: from file begin)" stop="(default: to file end)"
mode="hex(default)/dec"/>
<info>
<stream full="on(default)/off" file="..."/>
<message details="on(default)/off" file="..."/>
<tr101290 details="on(default)/off" file="..."/>
<headers details="on(default)/off" file="..."/>
<condition parameter="name" comparison="full/substring(default)">
<range value="min-max"/>
<equal value="value"/>
<less value="min"/>
<more value="max"/>
<not value="value"/>
</condition>
</headers>
</info>
</SA>

4.2 List of Commands
List of commands contains information on the command and all parameters which may be used within
a command, and their description.
Command

Description

<input/>
file

The tag is used to configure the input file;
Sets the input file path.

<output/>
storage
separator
delimiter
file

The tag is used to configure the input file;
Save output information into split or union storage (union (by default) / split);
Defines the symbol/string to separate the output data (; (by default) / ,));
Delimits the fractional part with floating point (. (by default) / ,));
Sets the output file path.

<info/>

The tag is used to define the type/-s of information for output.

<stream/>
full
file

The tag is used to output general information about the analyzed stream;
Contains information on data (on (by default) / off);
Sets the path for the output stream information.

<message/>
details
file

The tag is used to output messages that appear during analysis;
Contains information on message tree data (on (by default) / off);
Sets the output file path where the messages will be saved.

<tr101290/>
details
file

The tag is used to output TR101290 error that appear during analysis;
Contains information on message TR101290 error (on (by default) / off);
Sets the output file path where the messages will be saved.

<headers>
details
file

The tag is used to define the output headers information;
Contains full information on header data (on (by default) / off);
Sets the path to the output file with the headers information.
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4.3 Features of Stream Analyzer Command Line Tool
⚫
⚫
⚫
⚫
⚫
⚫

Analysis the whole array of video files automatically;
Addressing specific and complex challenges with a few lines of commands;
Retrieving submitted results as a text file in CSV format for easy viewing in Excel;
Customizing a sequence of commands to perform your specific tasks;
Accelerating and automating your regular tasks;
Getting access to most of Stream Analyzer functionality and resources through Stream
Analyzer Console.
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