User Guide Notices

Elecard Stream Analyzer v.4.3 User Guide
First edition: July, 2006
Date modified: 4 June, 2020.

For information, contact Elecard.
Tel: +7-3822-488-585
More information can be found at: http://www.elecard.com
For Technical Support, please contact the Elecard Technical Support Team: tsup@elecard.com

Elecard provides this publication “as is” without warranty of any kind, either expressed or implied. Whilst we make every attempt to ensure the accuracy and reliability of the information contained in the document, it may still contain technical inaccuracies or typographical errors. We would appreciate any feedback about inaccuracies or errors you may find when examining the documentation. While every precaution has been taken in the preparation of this document, the publisher and author assume no responsibility for errors or omissions. Nor is any liability assumed for damages resulting from the use of the information contained herein. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. Elecard may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time.

Other company, product, trademarks, and service names are trademarks or service marks of other companies or corporations.

Copyright © 2006-2020 Elecard. All rights reserved.
1. INTRODUCTION ................................................................................................................................. 4

1.1 PREFACE .............................................................................................................................................. 4
1.2 DESCRIBING ELECARD STREAM ANALYZER ..................................................................................... 4
   1.2.1 Supported Media Types .............................................................................................................. 4
   1.2.2 Features ...................................................................................................................................... 4

1.3 USING THIS GUIDE .......................................................................................................................... 5
   1.3.1 Purpose ....................................................................................................................................... 5
   1.3.2 Topics Covered .......................................................................................................................... 5

1.4 SYSTEM REQUIREMENTS .................................................................................................................. 5
   1.4.1 Software Requirements ............................................................................................................ 5

1.5 LICENSING AND TECHNICAL SUPPORT ......................................................................................... 5

1.6 ACTIVATING ELECARD STREAM ANALYZER ................................................................................... 6
   1.6.1 Sentinel License Protection ........................................................................................................ 6
   1.6.2 Flexera License Protection ......................................................................................................... 8
       1.6.2.1 Trial License ...................................................................................................................... 9
       1.6.2.2 Node-Locked License ....................................................................................................... 10
       1.6.2.3 Floating License .............................................................................................................. 11

2. GETTING STARTED ............................................................................................................................. 15

2.1 INSTALLING ELECARD STREAM ANALYZER ................................................................................. 15
2.2 UNINSTALLING ELECARD STREAM ANALYZER .............................................................................. 15
2.3 RUNNING ELECARD STREAM ANALYZER ...................................................................................... 15

3. USING ELECARD STREAM ANALYZER ............................................................................................. 16

3.1 INTRODUCTION ............................................................................................................................... 16
3.2 DESCRIBING ELECARD STREAM ANALYZER GUI ......................................................................... 16
   3.2.1 Menu ......................................................................................................................................... 16
   3.2.2 Explorer Panel ............................................................................................................................ 18
   3.2.3 Main Window Panel .................................................................................................................... 20
   3.2.4 Property Panel ........................................................................................................................... 21
   3.2.5 Hex Viewer Panel ....................................................................................................................... 22
   3.2.6 Messages Panel .......................................................................................................................... 22
   3.2.7 TR101-290 Panel ....................................................................................................................... 23
   3.2.8 Time Dynamics Panel ................................................................................................................. 25
   3.2.9 Graphics Panel ........................................................................................................................... 26
   3.2.10 Comments Panel ....................................................................................................................... 26
   3.2.11 EPG Panel ................................................................................................................................... 28
   3.2.12 Saving Stream Information ..................................................................................................... 28
   3.2.13 Options Window ...................................................................................................................... 28
   3.2.14 Command Line Tool ................................................................................................................. 30
       3.2.14.1 Features of Stream Analyzer Command Line Tool ........................................................... 34
       3.2.14.2 Launch of Stream Analyzer Command Line Tool ............................................................. 34
       3.2.14.3 List of Commands ............................................................................................................. 35
1. Introduction

1.1 Preface

Elecard Stream Analyzer is a powerful tool designed for syntax analysis of encoded media streams and presentation of the analysis log in a human readable form. Stream Analyzer operates with MPEG-1 Video/Audio, MPEG-2 Video/Audio, AAC, Dolby Digital Audio, AVC/H.264, VC1, HEVC/H.265, AV1 and VP9 contained in TS, PS, MP4, AVI, FLV, IVF and MKV (Matroska) files.

1.2 Describing Elecard Stream Analyzer

The following section defines the specifications and features of Elecard Stream Analyzer.

1.2.1 Supported Media Types

Elecard Stream Analyzer supports the following formats:

- MPEG-1 Video stream (ISO/IEC 11172-2);
- MPEG-2 Video stream (ISO/IEC 13818-2);
- AVC/H.264 Video stream (ISO/IEC 14496-10) and its Annex G (SVC) and Annex H (MVC);
- HEVC/H.265 Video stream (ISO/IEC 23008-2, MPEG-H Part 2);
- VP9 Bitstream Overview for Google VP9;
- AV1 Bitstream & Decoding Process Specification;
- MPEG-4 Video stream;
- VC-1 Video;
- MPEG-1/2 Audio Layer 1/2/3 (ISO/IEC 11172-3 and ISO/IEC 13818-3);
- Dolby Digital Audio (ATSC A-52);
- AAC (Advanced audio coding);
- LPCM (Linear Pulse Code Modulated Audio);
- SCTE-35 (ANSI/SCTE-35);
- DVB Subtitle (ETSI EN 300 743);
- MPEG-1 System Stream (MPEG-1, MPEG-1/2 Audio Layer 1/2/3, LPCM) (ISO/IEC 11172-1);
- MPEG-2 Transport Stream (MPEG-1/2, AVC, HEVC, MPEG-1/2 Audio Layer 1/2/3, LPCM, AC-3, AAC, SCTE-35, DVB Subtitle) (ISO/IEC 13818-1);
- MPEG-2 Program Stream (MPEG-1/2, AVC, HEVC, MPEG-1/2 Audio Layer 1/2/3, LPCM, AC-3, AAC) (ISO/IEC 13818-1);
- AVI file container (MPEG-1/2, AVC, HEVC, LPCM, AC-3, AAC);
- MP4 file container (MPEG-1/2, AVC, HEVC, VP9, AV1, VC-1, AC-3, AAC);
- MKV file container (MPEG-1/2, AVC, HEVC, VP9, AV1, MPEG-1/2 Audio Layer 1/2/3, AC-3, AAC);
- WebM file container based on MKV (VP9, AV1);
- IVF file container (VP9, AV1);
- FLV file container (AVC, AAC, LPCM).

1.2.2 Features

Elecard Stream Analyzer implements the following features:

- Selection of packets in a text;
• Selection of packets by PID and StreamID;
• Stream viewing in the hex, ascii and binary modes;
• Storing information about the stream and currently selected packets into a .CSV file;
• Search of elements by offset, PID and text;
• Transport stream error detection (ETSI TR 101 290) and analysis, error report generation;
• Interleaving analysis;
• Presentation of the interleaving between two streams as a diagram;
• Calculation of the overhead in transport, program and system streams;
• Bandwidth information;
• Customization main control output;
• MP4, AVI, MKV, FLV, IVF support;
• Cross platform (Windows, Mac, Linux version);
• Selection of the data portion for further saving;
• Dump elementary streams to file;
• Build graphics from parameters;
• Sharing comments between application instances and/or applications of Elecard StreamEye Studio set;
• Synchronization between applications of Elecard StreamEye Studio set (Binding mode);
• Console version.

1.3 Using this Guide

1.3.1 Purpose

This guide is intended to help the user utilize Elecard Stream Analyzer. It describes the Stream Analyzer GUI, settings and functions and provides instructions for Stream Analyzer use.

1.3.2 Topics Covered

Section 1: Introduction – provides a general overview of Stream Analyzer and describes the purpose of the document and its contents.

Section 2: Getting Started – describes how to install, uninstall, and run the Elecard Stream Analyzer program.

Section 3: Using Elecard Stream Analyzer – describes the Stream Analyzer GUI and provides instructions for comparing video streams and viewing the results of comparison.

1.4 System Requirements

1.4.1 Software Requirements

• Windows® 7/8/10 (64-bit)

1.5 Licensing and Technical Support

By installing, copying, or otherwise using the software product or any updates, you agree to be bound by the terms of the "Elecard" End-User License Agreement ("EULA"). This EULA is a legal agreement between you (either an individual or a single entity) and Elecard for the "Elecard" software product(s)
accompanying this EULA, which include(s) computer software and may include "online" or electronic documentation, associated media, and printed materials ("software product").
For technical support, please contact Elecard Technical Support Team: tsup@elecard.com.
For sales and licensing information contact Elecard Sales Department: sales@elecard.com.

1.6 Activating Elecard Stream Analyzer

1.6.1 Sentinel License Protection

Make sure that Sentinel License Manager software has been installed on your computer. License Manager is provided within the product installation pack for Windows OS and macOS and installed automatically.
License Manager is provided as a separate installation pack for Linux OS and should be installed manually.

Please note, Windows OS reinstallation will make the activated product license invalid.

To check that License Manager is properly installed, go to Sentinel Admin Control Center at http://localhost:1947. If you see your license information, the installation is successfully completed.

![Sentinel Admin Control Center](image)

**Figure 1. The License Manager with license information**

License Manager allows configuring, controlling, monitoring and looking through a list of available licenses. For more details on License Manager operation click the Help tab.

**Note. each page contains the Help tab related to this page only.**

There are two ways to activate Elecard Stream Analyzer: on-line and offline.

**On-line activation**

1. Be advised, that Internet connection is required for this type of activation.
2. Your purchase confirmation e-mail will contain a product key serial number for on-line activation. Make sure you inform your account manager that you are looking to activate the
product on-line.

3. Enter the received product key XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXXXXX in the *On-line activation with a product key* field, as shown below, and click Activate. Your application is successfully activated.

![Figure 2. On-line activation with product key](image)

**Offline activation**

For Elecard Stream Analyzer activation, a C2V (client-to-vendor) file should be created. To create the C2V file follow the steps:

1. Open the **File** tab and select **Options** in the drop-down menu.
2. A dialog window should open. Open the **License** tab.
3. Select HASP-SL for PC-based or HASP-HL for dongle-based activation in the *Offline activation with license files* field. Note, if you select a PC-based (HASP-SL) activation, full featured activated Elecard Stream Analyzer will run only on this particular hardware. If you have Elecard dongle, plug it into a free USB port on your computer and select dongle-based (HASP-HL) activation. It will be possible to use Elecard Stream Analyzer on any hardware with the dongle plugged in.

![Figure 3. Offline activation with license files](image)

4. Click the **Collect license information** button. The Save File dialog box should open. Click **Save** and save the C2V file to a required directory. Send the saved C2V file to Elecard Sales at sales@elecard.com.
5. After receiving the V2C file containing license information back from Elecard Sales save the received file to a required directory. Open the **File** tab and select **Options** in the drop-down menu again. Open the **License** tab and click **Apply license update** (see Figure 4). The file selection dialog box should appear. Choose the received V2C file and click **OK**. Your application is successfully activated.

### 1.6.2 Flexera License Protection

Make sure that Flexera Software LLC has been installed on your computer. Flexera Anchoring Service is provided within the product installation pack for Windows OS and installed automatically.

*Please note, Windows OS reinstallation will make the activated product license invalid.*

To check that Flexera Anchoring Service is properly installed, go to Task Manager and find there Flexera Software LLC.
1.6.2.1 Trial License

Trial licenses are included in your application copy with limited functionality for 30 days. An expired version of the application allows to work only with first 2 seconds of a video stream. Previously installed trial licenses can be checked via application by clicking **Options > License** tab or the **client-activation** command line tool.

The **client-activation** command line tool is located in the installed application directory. The default path is `C:\Program Files\Elecard\Elecard StreamEye Studio 4.6\Elecard Stream Analyzer 4.3`
To view licenses installed, type `client-activation.exe -view` in the command line. Information about all types of installed licenses, including other products based on Flexera license, active features and expiration data will be returned.

**Please note,** with `client-activation` command line tool only trial licenses can be viewed.

In case the trial license was not activated during the installation process, it can be activated later via GUI or the command line tool.

**GUI activation**

1. Open the **File** tab and select **Options** in the drop-down menu.
2. A dialog window should open. Open the **License** tab.

   ![Elecard Stream Analyzer GUI – The Part of Options Tab](image)

3. Click **Select file** to choose the received trial license. A trial license file has the `.asr` extension.
4. The information about your applied license will be shown in the field above. Your application is activated.

**Command line tool activation**

1. Open the `client-activation` tool in the command line.
2. Type `client-activation.exe -local <full path to your license file>`. Your application is activated.

### 1.6.2.2 Node-Locked License

This type of license is permanent and used for only one PC in case of PC-based or dongle-based activation.

**Please note,** Windows OS reinstallation or hardware change will make the activated product license invalid.

For Elecard Stream Analyzer activation, a **hostID** value should be saved. To find the hostID value and activate the application, follow the steps:
1. Open the **File** tab and select **Options** in the drop-down menu.
2. A dialog window should open. Open the **License** tab.
3. At the bottom of window find the hostID value. To copy hostID, select the number and click right button of the mouse.

![Figure 9. Elecard Stream Analyzer GUI – HostID Number Location](image)

4. Save the found hostID value and send it to Elecard Sales at sales@elecard.com.
5. After receiving the LIC file, open the **File** tab and select **Options** in the drop-down menu and then open the **License** tab. Click **Select Directory** to specify the folder where LIC files are kept.

![Figure 10. Elecard Stream Analyzer GUI – License Tab: LIC files Selecting Directory](image)

**Please note**, moving LIC files will make the activated product license invalid.

6. Choose the directory with the received file and click **OK**. Your application is successfully activated.

For the dongle-based activation, the LIC file is also needed.

### 1.6.2.3 Floating License

Make sure that **Flexera Floating Service** is installed on your license server machine. Floating service is provided as a separate installation pack for Windows OS and should be installed manually. Flexera Floating Service may be used for the software activation or dongle-based activation.

**Please note**, Windows OS reinstallation or hardware change will make the activated product license invalid.

To check that Floating Service is properly installed, go to Flexera Publisher at [http://localhost:8090](http://localhost:8090). If Flexera Service Dashboard is opened, the installation is successfully completed.
Figure 11. Flexera Service Dashboard

Flexera Floating Service Dashboard allows to watch and manage floating license processes.

Information on finding of the HostID value and activation of LIC files can be found in the following section (1.6.2.2 Node-Locked License). To find the HostID value and activate the application via Flexera Floating Service, follow the steps:

1. Open [http://localhost:8090](http://localhost:8090) and log in with following credentials:
   - User Name: admin
   - Password: admin

   **Please note, for the first time Flexera Floating Service will ask you to change the default password**

Go to Administration page and get all values of the Ethernet Address fields.
Figure 12. System Information Tab

2. Save the received hostID value and send it to Elecard Sales at sales@elecard.com.

3. After receiving the LIC file open Flexera Floating Service on Administration page and then go to Vendor Daemon Configuration tab.
4. Click **Import License** and choose the received LIC file. To import the file, click the corresponding button. Your application is successfully activated.

---

**Please note**, once the import is complete, the file will be copied in the **Flexera Floating Service install folder**.

For the dongle-based floating activation, the LIC file is also needed.
2. Getting Started

The following section details the procedures for installing and running Elecard Stream Analyzer.

2.1 Installing Elecard Stream Analyzer

Elecard Stream Analyzer is supplied as part of Elecard StreamEye Studio or as a standalone application. The application is installed via Elecard StreamEye Studio installer or Elecard Stream Analyzer installer. Depending on the purchased product or version, the installation file is located:

- in Elecard folder as a separate application;
- in Elecard folder as part of Elecard StreamEye Studio.

1. Run Elecard Stream Analyzer Setup.
2. To complete installation, follow the onscreen instructions.
3. When setup has finished installing all the necessary files on your computer, the Elecard Stream Analyzer has been successfully installed dialog box will appear, and the program is ready to run. You do not need to reboot your computer.

2.2 Uninstalling Elecard Stream Analyzer

To uninstall Elecard Stream Analyzer:

1. Click Start → Programs → Elecard → Elecard Stream Analyzer X.X → Uninstall Elecard Stream Analyzer X.X.
2. Follow the on-screen instructions to complete the Elecard Stream Analyzer uninstallation.

2.3 Running Elecard Stream Analyzer

To run Elecard Stream Analyzer click Start → Programs → Elecard → Elecard Stream Analyzer X.X.
3. Using Elecard Stream Analyzer

3.1 Introduction

The following section describes the Elecard Stream Analyzer GUI (graphic user interface), its features and instructions for stream analysis. The Elecard Analyzer is an advanced video analysis software tool standing out for its simple user-friendly interface and in-depth statistics analysis.

3.2 Describing Elecard Stream Analyzer GUI

The following section describes the Elecard Stream Analyzer GUI.

![Elecard Stream Analyzer GUI](image)

Figure 15. Elecard Stream Analyzer GUI

3.2.1 Menu

The following table describes the Elecard Stream Analyzer menu.

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open file</td>
<td><img src="image" alt="Open file" /></td>
<td>Opens a new media file for analysis.</td>
</tr>
<tr>
<td>Reopen</td>
<td><img src="image" alt="Reopen" /></td>
<td>Reopens a list of recently opened files.</td>
</tr>
<tr>
<td><strong>Reopen Last File</strong></td>
<td>Reopens the last opened file.</td>
<td></td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------------------------</td>
<td></td>
</tr>
<tr>
<td><strong>Save</strong></td>
<td>Allows selecting file information to be saved:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Stream Info – saves all information on a stream;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Dump – extracts and saves a piece of a file or an elementary stream and allows choosing the required data portion.</td>
<td></td>
</tr>
<tr>
<td><strong>Close</strong></td>
<td>Closes the opened file.</td>
<td></td>
</tr>
<tr>
<td><strong>Close All</strong></td>
<td>Close all opened files.</td>
<td></td>
</tr>
<tr>
<td><strong>Binding mode</strong></td>
<td>Enables or disables the Binding mode:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Leader – allows sending comments, commands on interface or positioning changes to other applications;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Follower – allows receiving comments, commands from other applications.</td>
<td></td>
</tr>
<tr>
<td><strong>Open comments</strong></td>
<td>Opens comments from the XML file.</td>
<td></td>
</tr>
<tr>
<td><strong>Save comments</strong></td>
<td>Saves comments to the XML file.</td>
<td></td>
</tr>
<tr>
<td><strong>Copy the Full Path</strong></td>
<td>Copies full path to the opened file.</td>
<td></td>
</tr>
<tr>
<td><strong>Open Containing Folder</strong></td>
<td>Opens the current file location in Explorer.</td>
<td></td>
</tr>
<tr>
<td><strong>Open with</strong></td>
<td>Opens the current file with an external application (the application name and its path are set in the Open With List field by opening Options – Main. Player is set by default).</td>
<td></td>
</tr>
<tr>
<td><strong>Options</strong></td>
<td>Opens the program settings dialog (Main, Binding, License).</td>
<td></td>
</tr>
<tr>
<td><strong>Exit</strong></td>
<td>Exits the application.</td>
<td></td>
</tr>
</tbody>
</table>

### Navigation

| **Offset** | Enables searching by the offset. |
| **Search text box** | Enables searching the necessary byte sequence in the file (helps to search for start-codes). |
| **Previous / Next** | Switches the searching results: previous / next. |

### View

| **Explorer** | Enables/disables the Explorer panel |
| **Property Sync mode** | Enables/disables the Property panel:  |
| **Compare mode** | • automatically changes data displayed in the Property panel |
| **Dump mode** | • compares the chosen packet with the selected one. |
| **Hex Viewer** | Enables/disables the Hex Viewer panel |
| **Time Dynamics** | Enables/disables the Time Dynamics panel |
| **Messages** | Activates the Messages panel |
| **TR101-290** | Activates the TR101-290 panel |
| **Graphics** | Enables/disables the Graphics panel |
| **Comments** | Enables/disables the Comments panel |

### Help
3.2.2 Explorer Panel

To open the Explorer panel, click View – Explorer.

This panel shows the stream hierarchical tree and allows managing information display in the Main window panel. Left-click on the element shows all properties in the Property panel. Right-click on the element shows the shortcut menu.

The Percentage field shows the percentage rate of an element in the whole stream.

When choosing some stream element, you can see two more functions in the Property panel. The Dump button saves the dump file.

Use checkboxes to select data that you need displayed in the Main Window panel. MP4 streams have descriptive headers that contain detailed information about MP4 boxes (atoms), which is displayed in the panel.
AVI streams have descriptive headers that contain detailed information about AVI chunks, which is displayed in the panel.

MKV streams have descriptive headers that contain detailed information about MKV elements, which is displayed in the panel.
3.2.3 Main Window Panel

This panel contains information about packets.

Circles on the left side of the panel indicate type of information displayed. The red circle stands for an error, the blue one is either a warning or a message. Offset indicates the beginning of the packet position in the file. Types of packets are color coded. Braces show the parameters that can be chosen in the Property panel.

The scrollbar indicates red and blue messages found in the displayed packets. Search results are highlighted orange.

Click the packet to see corresponding data in the Property panel, Hex Viewer panel and Messages panel. Double left-click on the packet in the Main Window panel opens property data of the corresponding packet. To select the required data range, left-click or right-click and press the Shift key.
### 3.2.4 Property Panel

This panel indicates properties of the chosen packet.

![Property Panel](image)

**Figure 21.** Elecard Stream Analyzer GUI – Property Panel – Detailed Information about packet (from the Main Window Panel)

![Property Panel](image)

**Figure 22.** Elecard Stream Analyzer GUI – Property Panel – Detailed Information about stream (from the Explorer Panel)

![Property Panel](image)

**Figure 23.** Elecard Stream Analyzer GUI – Property Panel – Detailed Information about chosen box (atom) (from the Explorer Panel)

To display a parameter in the Main Window panel, right-click on the necessary parameter and choose **Show in header title**. To hide a parameter, click on the ![button](image) button in front of a parameter in the Property panel.

**Compare mode** – the chosen packet will be compared with the previous chosen one. The differences in parameters will be highlighted blue.
Sync mode – automatically changes data displayed in the Property panel without left-clicking the Main Window panel

Dump – a function in the explorer mode for saving elementary stream.

### 3.2.5 Hex Viewer Pane

The HEX viewer represents a file in the hex mode and allows navigation by the offset. The buttons also provide ascii and binary modes.

In the Columns drop-down list, you can choose number of bytes to show in the panel.

The Offset field allows searching the necessary byte sequence in the file (helps to search for start-codes).

### 3.2.6 Messages Panel

The Messages panel displays a log of the stream errors analysis. The left panel is used to form the list of errors indicated in the log. It also provides a list of possible error or message types. If an error occurs, it is highlighted blue and you see the number of errors or messages found in the file. The right panel...
provides a list of occurred errors or messages. The red color stands for first priority errors. The blue color is the indicator of warnings and errors of second and third priority.

Double-clicking the line in the right panel sets position in **Main Window** to the packet comprising the selected error.

### 3.2.7 TR101-290 Panel

The **TR101-290** panel displays a log of the transport stream analysis. The left panel is used to form the list of errors indicated in the log. It also provides a list of possible error or message types. If an error occurs, it is highlighted blue and you see the number of errors or messages found in the file. The right panel provides a list of occurred errors or messages. The red color stands for first priority errors. The blue color is the indicator of warnings and errors of second and third priority.

Double-clicking the line in the right panel sets position in **Main Window** to the packet comprising the selected error.

If an indicator is set, then the TS is in error. However, since the indicators do not cover the entire range of possible errors, it cannot be concluded that there is no error if the indicator is not set.

If the **TS sync loss** indicator is activated then all other indicators are invalid. Each indicator is activated only as long as at least one of the description lines is fulfilled.

*Note: In the case of indicators requiring a minimum repetition rate of sections, it means that each and every section that is present for this table should have the stated repetition rate.*

Any test equipment intended for the evaluation of these parameters should report test results by means of the indicators itemized in the second column of the tables followed below. The tables describe detectable errors according to their priority types.

### Table 2. First Priority Errors

<table>
<thead>
<tr>
<th>Error</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TS sync loss</td>
<td>Loss of synchronization with consideration of hysteresis parameters.</td>
</tr>
<tr>
<td>Sync. byte error</td>
<td>Sync_byte is not equal to 0x47</td>
</tr>
<tr>
<td>PAT error</td>
<td>Sections with table_id 0x00 do not occur at least every 0.5 s on PID 0x0000</td>
</tr>
<tr>
<td></td>
<td>Section with table_id other than 0x00 found on PID 0x0000</td>
</tr>
<tr>
<td></td>
<td>Scrambling_control_field is not 00 for PID 0x0000</td>
</tr>
<tr>
<td>Continuity count error</td>
<td>Incorrect packet order</td>
</tr>
<tr>
<td></td>
<td>a packet occurs more than twice lost packet</td>
</tr>
<tr>
<td>PMT error</td>
<td>Sections with table_id 0x02, (i.e. a PMT), do not occur at least every 0.5 s on each program_map_PID which is referred to in the PAT.</td>
</tr>
<tr>
<td></td>
<td>Scrambling_control_field is not 00 for all packets containing information of sections with table_id 0x02 (i.e. a PMT) on each program_map_PID which is referred to in the PAT.</td>
</tr>
<tr>
<td>PID error</td>
<td>Referred PID does not occur for a user specified period.</td>
</tr>
</tbody>
</table>
### Table 3. Second Priority Errors

<table>
<thead>
<tr>
<th>Error</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transport error</td>
<td>Transport_error_indicator in the TS-Header is set to &quot;1&quot;</td>
</tr>
<tr>
<td>CRC error</td>
<td>CRC error occurred in CAT, PAT, PMT, NIT, EIT, BAT, SDT or TOT table</td>
</tr>
<tr>
<td>PCR repetition error</td>
<td>Time interval between two consecutive PCR is longer than 40 ms</td>
</tr>
<tr>
<td>PCR discontinuity indicator error</td>
<td>The difference between two consecutive PCR values (PCRi+1 – PCRi) is outside the range of 0...100 ms without the discontinuity_indicator set</td>
</tr>
<tr>
<td>PCR accuracy error</td>
<td>PCR accuracy of selected program is not within ±500 ns</td>
</tr>
<tr>
<td>PTS error</td>
<td>PTS repetition period is longer than 700 ms</td>
</tr>
<tr>
<td>CAT error</td>
<td>Packets with transport_scrambling_control not 00 present, but no section with table_id = 0x01 (i.e. a CAT) present</td>
</tr>
<tr>
<td></td>
<td>Section with table_id other than 0x01 (i.e. not a CAT) found on PID 0x0001</td>
</tr>
</tbody>
</table>

### Table 4. Third Priority Errors

<table>
<thead>
<tr>
<th>Error</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NIT actual error</td>
<td>Section with table_id other than 0x40 or 0x41 or 0x72 (i.e. not an NIT or ST) found on PID 0x0010</td>
</tr>
<tr>
<td></td>
<td>No section with table_id 0x40 (i.e. an NIT_actual) in PID value 0x0010 for longer than 10 s.</td>
</tr>
<tr>
<td></td>
<td>Any two sections with table_id = 0x40 (NIT_actual) occur on PID 0x0010 within a specified value (25 ms or lower).</td>
</tr>
<tr>
<td>NIT other error</td>
<td>Interval between sections with the same section_number and table_id = 0x41 (NIT_other) on PID 0x0010 longer than a specified value (10s or higher).</td>
</tr>
<tr>
<td>SI repetition error</td>
<td>Repetition rate of SI tables is outside of the specified limits</td>
</tr>
<tr>
<td>Unreferenced PID</td>
<td>PID (other than PMT_PIDs, PIDs with numbers between 0x00 and 0x1F or PIDs user defined as private data streams) is not referred to by a PMT or a CAT within 0.5 s</td>
</tr>
<tr>
<td>SDT actual error</td>
<td>Sections with table_id = 0x42 (SDT, actual TS) is not present on PID 0x0011 for more than 2 s</td>
</tr>
<tr>
<td></td>
<td>Sections with table_ids other than 0x42, 0x46, 0x4A or 0x72 found on PID 0x0011.</td>
</tr>
<tr>
<td></td>
<td>Any two sections with table_id = 0x42 (SDT_actual) occur on PID 0x0011 within a specified value (25 ms or lower).</td>
</tr>
<tr>
<td>SDT other error</td>
<td>Interval between sections with the same section_number and table_id = 0x46 (SDT, other TS) on PID 0x0011 longer than a specified value (10s or higher).</td>
</tr>
<tr>
<td>EIT actual error</td>
<td>Section '0' with table_id = 0x4E (EIT-P, actual TS) is not present on PID 0x0012 for more than 2 s</td>
</tr>
<tr>
<td></td>
<td>Section '1' with table_id = 0x4E (EIT-F, actual TS) is not present on PID 0x0012 for more than 2 s</td>
</tr>
<tr>
<td></td>
<td>Sections with table_ids other than in the range 0x4E - 0x6F or 0x72 found on PID 0x0012.</td>
</tr>
<tr>
<td></td>
<td>Any two sections with table_id = 0x4E (EIT-P/F, actual TS) occur on PID 0x0012 within a specified value (25ms or lower).</td>
</tr>
<tr>
<td>EIT other error</td>
<td>Interval between sections '0' with table_id = 0x4F (EIT-P, other TS) on PID 0x0012 longer than a specified value (10s or higher);</td>
</tr>
<tr>
<td></td>
<td>Interval between sections '1' with table_id = 0x4F (EIT-F, other TS) on PID 0x0012 longer than a specified value (10s or higher).</td>
</tr>
<tr>
<td>EIT PF error</td>
<td>If either section ('0' or '1') of each EIT P/F subtable is present both must exist. Otherwise EIT_PF_error should be indicated</td>
</tr>
<tr>
<td>RST error</td>
<td>Sections with table_id other than 0x71 or 0x72 found on PID 0x0013. Any two sections with table_id = 0x71 (RST) occur on PID 0x0013 within a specified value (25 ms or lower).</td>
</tr>
</tbody>
</table>
### 3.2.8 Time Dynamics Panel

The **Time Dynamics** panel represents the interleaving between two streams as a diagram. To specify the streams, use the drop-down lists in the panel.

#### Figure 27. Elecard Stream Analyzer GUI – Time Dynamics Panel

The chart can be built using DTSs or PTSs. If DTSs and PTSs are used together, the DTS values are used as primary ones. If DTS is absent, the PTS values are used.

These visualization options allow selecting the following Base stream characteristics for analysis (if data exists in the stream):

- **PTS/DTS Dynamics** – indicates variation of PTS/DTS with the Offset changing for the selected PID
- **PCR Dynamics** – indicates variation of PCR with the Offset changing for the selected PID
- **PCR/PTS Dynamics** – indicates variation of PTS/DTS in relation to the PCR values with the Offset changing for the selected PID
- **Offset/PCR Dynamics** – indicates variation of Offset between the PCR values for the selected PID

Moving the cursor over the window, you can see the values corresponding to the given points of the graph. Left click pins the cursor on the graph. Double-click displays the given packet in **Main Window**.

Clicking the **Fit** button you can resize the graphic, fitting it to your screen.

Buttons and zoom the graphic in and out, respectively.
3.2.9 Graphics Panel

The Graphics panel serves to compare parameters of the streams. You can add several parameters to compare. Go to the Property panel, right-click on the necessary parameter, choose Add to Graphic Control. The parameter will be added to the Graphics panel. The panel allows setting up visual representation of data. The graphic can be viewed in Line, Bar and Transition modes. Also, you can choose ranging by Offset or by Count in the drop-down menu.

![Graphics Panel](image)

Figure 29. Elecard Stream Analyzer GUI – Graphics Panel

Clicking the Fit button you can resize the graphic, fitting it to your screen.

Buttons + and − zoom the graphic in and out, respectively.

Stream structure – saves stream structure in the Explorer panel.

Full stream structure – saves only checked elements in the Explorer panel.

Messages – saves general info about errors.

Message details – saves all errors with their descriptions.

Visible elements – saves only opened elements in the Main Window panel.

Element data – saves all elements in the Main Window panel.

3.2.10 Comments Panel

The Comments panel is designed for team work: share comments on a specific frame or group of frames in the stream, navigation and switching between different instances of the same application or different applications contained in Elecard StreamEye Studio. Comments are created in the Main Window panel of the application by left-clicking (or right-clicking and pressing the shift button) and selecting the required field.
The **Comment** dialog should open. Enter comments in the corresponding field.

![Elecard Stream Analyzer GUI – Comments Panel](image)

**Figure 30.** Elecard Stream Analyzer GUI – Comments Panel

The comment parameters can be edited or changed before or after they are saved. To save the comment click **File ->Save Comments** and select the folder. When the comment is chosen, its position is displayed in **Main window** and highlighted green.

To edit, remove or send comments using the **Binding** mode, open the context menu by right-clicking. The **Send** option enables you to pass the selected comment to the other application of StreamEye Studio set or the other instance of Stream Analyzer. To select an application from which messages should be
received or to select a type of messages to be received, go to the Options tab – Binding or see more details in the Options Window section.

### 3.2.11 EPG Panel

![EPG Panel](image)

**Figure 32. Elecard Stream Analyzer GUI – EPG Panel**

The EPG panel displays scheduling information for current and upcoming broadcast programming. The Text mode represents programming information in a column. The TimeLine mode shows both information column and timeline field with time stamps. In case the successive timestamps are presented in a stream, space between them can be distributed by clicking the + and – buttons in the TimeLine mode. To see detailed information about the programming, hover cursor over its headline.

### 3.2.12 Saving Stream Information

The Save option allows saving different types of data: the stream itself, stream structure and information, headers, messages, errors, elements, comments, etc. To select and configure the data to be saved, open the Save tab from the File drop-down menu or click the button.

To save only information about the stream (without saving the stream as it is), select the Stream Info tab. A dialog window should open.
Stream structure – saves stream structure in the Explorer panel.

Full stream information – saves only checked elements in the Explorer panel.

Range – allows selecting a range to save data contained there:
  - All – saves information on the whole stream;
  - Offset – saves information on a stream portion limited by the specified offsets.

Messages – saves general information about errors.

Message details – saves errors with all details.

TR101-290 – saves general information about types of errors and their number.

TR101-290 details – saves detailed information about errors.

Headers – saves all headers without their structure.

Visible only – saves only headers selected in the Explorer panel and displayed in the Main Window panel.

Headers details – saves all headers with their structures selected in the Explorer panel and displayed in the Main Window panel.

To save a stream or its portion, select the Dump tab. A dialog window should open.
Select an Elementary stream to be dumped as a whole or within a specified range.

**Range** – allows selecting a range to save data contained there:
- All – saves information on the whole stream;
- Offset – saves information on a stream portion limited by the specified offsets.

### 3.2.13 Options Window

To open the Options window, select the **Options** tab from the File drop-down menu or click the button. The Options window allows opening a file with an external application, specifying the application name and path, specifying the number of files in a list, saving data, configuring **Binding mode** settings.

Specify the number of recent files to be displayed in a list. The default value is 10 files.
On attempt to open a file from a list that does not exist any longer, a message notifying that the file is missing occurs. It is recommended to delete missing files from the list. To enable automatic deletion of missing files, set the checkbox for **Delete missing recent files from list automatically**.

**Color theme** allows selecting light (default) or dark colors of the GUI background.

To open the file currently opened in Stream Analyzer with another application, specify its name and path in the **Open with** field according to parameters specified there. The parameters path and shortcut are optional. If the path parameter is not specified, default application supporting a file format and installed in the system is opened. Each string specified in the **Open with** field corresponds to an individual item in the menu **File – Open with**, that allows easy switching between applications or players after configuring the field.
The Save tab in the Options dialog allows saving data using the following options:

- **Decimal separator in .csv file** - allows selecting decimal comma or decimal dot to separate an integer part from a fractional one of a real number.
- **Data delimiter in .csv file** - allows selecting comma or semicolon to specify boundaries in data stream.

To configure the **Binding mode** settings, open the corresponding tab. The **Binding mode** allows exchanging information between applications contained in Elecard StreamEye Studio, selecting applications from which messages should be received, type of the messages to be received, synchronizing application window size and switching between controls.
Figure 37. Elecard Stream Analyzer GUI – Options – Binding Tab

**Receive messages from the application** – allows selecting the applications contained in Elecard StreamEye Studio from which messages are received: StreamEye, StreamAnalyzer, VideoQuest.

**Messages type to be received from the selected application** – allows selecting a type of messages to be received from the selected applications:

- **Position** – positioning in bitstream in different applications but within the same video file (available only if the same video file is opened in different applications).
- **Comments** – allows receiving comments from the selected applications (available for all selected applications contained in Elecard StreamEye Studio).

**GUI Synchronization** – allows synchronizing the application window size and switching between internal controls (available for StreamAnalyzer only).

### 3.2.14 Command Line Tool

Elecard Stream Analyzer functionality is available in console version now, so you can run the tool from the command line.

Stream Analyzer Command Line tool is designed for insight into MPEG-1 Video/Audio, MPEG-2 Video/Audio, AAC, Dolby Digital Audio, AVC/H.264, VC1, HEVC/H.265, AV1 and VP9 contained in TS, PS, MP4, AVI, FLV, IVF and MKV (Matroska) file formats.

Stream Analyzer Command Line tool allows automatic analysis of video arrays. You can customize a sequence of commands to perform your specific tasks and automate your routine tasks.
3.2.14.1 Features of Stream Analyzer Command Line Tool

- Analysis the whole array of video files automatically;
- Addressing specific and complex challenges with a few lines of commands;
- Retrieving submitted results as a text file in CSV format for easy viewing in Excel;
- Customizing a sequence of commands to perform your specific tasks;
- Accelerating and automating your regular tasks;
- Getting access to most of Stream Analyzer functionality and resources through Stream Analyzer Console.

3.2.14.2 Launch of Stream Analyzer Command Line Tool

To streamline automatic analysis of several files the following rules are introduced. They reassign input and output parameters for configuration files.

Get to the command prompt by clicking Start->Run and type 'cmd'. Then enter the command to start the application first and proceed with the command line options. In general, the syntax is as follows:

SAConsole config.xml /in:input.ts /out:output

Note: You should not relocate the <product> console without all the other applications of the product contained in the installation pack, otherwise the console application will not start.

Notes on the command line rules:

1. Parameters with default value are not required and can be omitted;
2. Rules for input and output file names:
   - parameter /in:<file path> in the command line overwrites the value of the tag <input/> in the configuration file;
   - parameter /out:<file prefix> in the command line overwrites the value of the tag <output/> in the configuration file;
   - if <output/> tag is missing (or not specified), output file names are formed from input file name plus suffix (if the latter is specified);
   - if output file for a tag/section is not specified, the output file name for the tag/section is formed from the name specified in the <output/> tag plus suffix depending on the name of the tag/section, e.g. ".message.csv", ".header.csv", etc.

<table>
<thead>
<tr>
<th>in</th>
<th>input file path</th>
</tr>
</thead>
<tbody>
<tr>
<td>out</td>
<td>output files prefix</td>
</tr>
<tr>
<td>file path</td>
<td>path to the file</td>
</tr>
<tr>
<td>config path</td>
<td>path to the config file</td>
</tr>
<tr>
<td>sfx</td>
<td>suffix of all output files in config</td>
</tr>
<tr>
<td>dc</td>
<td>use current run directory as default path for files</td>
</tr>
</tbody>
</table>

Sample Config.xml file – contains all the commands performed by the application and reflects overall operation results:

```
<SA version="1">
<input file="..."/>
<output storage="union(default)/split" separator=";(default)/"," delimiter=".(default)/"," file="..."/>
```
### 3.2.14.3 List of Commands

**List of commands** contains information on the command and all parameters which may be used within a command, and their description.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;input&gt;</code> file</td>
<td>The tag is used to configure the input file; Sets the input file path.</td>
</tr>
<tr>
<td><code>&lt;output&gt;</code> file</td>
<td>The tag is used to configure the input file; Saves output information into split or union storage (union (by default) / split); Sets the output file path.</td>
</tr>
<tr>
<td><code>&lt;info&gt;</code></td>
<td>The tag is used to define the type/-s of information for output.</td>
</tr>
<tr>
<td><code>&lt;stream&gt;</code> full file</td>
<td>The tag is used to output general information about the analyzed stream; Contains information on data (on (by default) / off); Sets the path for the output stream information.</td>
</tr>
<tr>
<td><code>&lt;message&gt;</code> details file</td>
<td>The tag is used to output messages that appear during analysis; Contains information on message tree data (on (by default) / off); Sets the output file path where the messages will be saved.</td>
</tr>
<tr>
<td><code>&lt;tr101290&gt;</code> details file</td>
<td>The tag is used to output TR101290 error that appear during analysis; Contains information on message TR101290 error (on (by default) / off); Sets the output file path where the messages will be saved.</td>
</tr>
<tr>
<td><code>&lt;headers&gt;</code> details file</td>
<td>The tag is used to define the output headers information; Contains full information on header data (on (by default) / off); Sets the path to the output file with the headers information.</td>
</tr>
</tbody>
</table>